
Exercise 4 

4. Coordinate Geometry 
In the normal workflow, Survey personnel develop preliminary centerlines based on 
the project’s Transportation Planning Report (TPR-See Appendix A). When 
the survey data is passed on to Design, we have to review those preliminary 
centerlines to determine if they can be used for the proposed design of the roadway. 
Several issues must be addressed including: 

• Standard Design Specifications – do curves meet design specs 
• Encroachment – can a vertical alignment be developed which when used with 

the centerline and typical section does not encroach excessively on 
properties, historical or archeological sites, wetlands, etc. 

• Constructability issues – If traffic is to be maintained on existing roads can 
the roadway be built as designed while maintaining traffic flow. 

With this in mind this exercise takes a preliminary centerline as it might come from 
Survey and goes through the processes Design might use to alter that centerline 
chain to meet the requirements encountered through the design process. 

As we work with this proposed centerline, we will look at different methods that 
GEOPAK provides to store coordinate geometry including basic COGO and 
Horizontal Alignment tools. 

I.) Basic COGO 
1) Open the MicroStation file  

C:\Projects\Roane\SR95PoplarCr\ROSR95Alignments.dgn 

Access Project Manager. 

2) Select the Coordinate Geometry icon from the Project Manager workflow 
dialog. 
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3) The Coordinate Geometry dialog opens as shown below. 

 

This dialog is completely re-sizable, so you can re-size and position it where you’re 
most comfortable. 
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a)  COGO Interface 
In the next few steps, we’ll take some time to familiarize ourselves with the COGO 
interface. 

4) All basic COGO commands are available through the drop down options from the 
COGO menu bar. These include the creation of objects such as points, curves & 
chains, as well tools to report information on those objects.  

These tools can also be activated via the icons at the top. The icons shown at the 
top are customizable by the user. 

 
Click on the drop down option  
View → Icons → Customize This Group. The following dialog is opened. 

 

Scroll through the list and make sure the following are clicked on. 

• Input File Utility  (under File) 

• Equate  (under Element/Point) 

• Copy  (under Element/Curve) 

• Station  (under Element/Chain) 
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• Store From Elements  (under Element/Chain) 

• Store Transition Chain  (under Element/Chain) 

• Elevation  (under Element/Profile) 

• Navigator  (under Tools) 

• Locate Traverse  (under Tools) 

In upcoming exercises, we will be using these tools. 

Click OK to save settings. 

5) On the Coordinate Geometry dialog face there are options for decimal values. 
These are the same controls we accessed previously through User Preferences.  

By default, the Distance Decimal and Angle Decimal Second options are turned on. 
We will not be using those in these exercises, so go to View → Format and turn 
them off.  
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It should be noted that these decimal values should only be changed 
temporarily from the project default values since they will affect graphical 
displays.  

Occasionally, the Distance Decimal and Station Decimal options are handy 
to have out when checking values that were previously rounded off to the standard 2 
decimal places.  

6) The first tool we want to look at is Navigator. This tool will allow you to access any 
object stored in the project’s GPK file. Click on the Navigator icon to open it up. 

 

 

Click on the Element option list to look at other object types stored in the GPK file. 

The Navigator is re-sizable and various types of data information are available 
depending on which Element option is active.  

 

NOTE:  
For this class, we are using a stripped down version of the GPK file which only 
contains the preliminary centerline. Normally this file would also include all other 
features located by Survey (topo, dtm, parcels). 
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7) Click on the Element option button and set it to Chain. 

8) Click on preliminary chain SR95 and then click on the Print\Describe 
Element icon (2nd from right). 

 

9) In the COGO output area the coordinate geometry output of the chain is printed. 
Review the objects which make up this chain. 
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10) From our review we can see chain SR95 consists of : 

Point S101 
Spiral Curve SC102  (Spiral SC102B, Curve SC102, Spiral SC102A) 
Simple Curve SC103 
Point S104  

Go to level display and turn off all levels except for GPK 
Visualizations so you can see the created chain. 

NOTE:  
Since all of these objects were stored by Survey, they all include the prefix letter S. 
Any objects which we store should begin with the letter D for Design that way we 
can tell who stored any given object in the GPK file. 

Spirals always include the ending letters, B (for Back) or A (for Ahead). 

b)  Re-name Preliminary Centerline Chain 
It has been determined that this project should include the Poplar Creek drainage 
structure so we need to extend the centerline back.  

Since we need to keep a copy of the original preliminary centerline for reference and 
also must keep the proposed centerline name as SR95 to maintain the intelligence 
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on smart labels placed for present R.O.W. flags, we will first save the preliminary 
centerline under another name and then revise the original for the new proposed 
centerline. 

11) In the COGO dialog, make sure the visualization options are set to Disable 
Visualization & OFF (Feature). We do not want the preliminary chain to be 
visualized (graphically displayed). 

 

12) Toggle on the Redefine option. Open up COGO Navigator to Chain and double 
click on the preliminary centerline chain SR95. 

In the Store Chain dialog change the name to SR95PRELIMINARY and click 
on Store Chain. COGO element names can be up to 15 characters long. 

 

13) Back in the Navigator, check to make sure you have the new chain 
SR95PRELIMINARY listed, then click on chain SR95 and click on the Delete 

icon . When prompted, click Yes to delete the selected elements. 

c)  Locate New Beginning Point 
Now, we can set up the objects for our new proposed chain SR95. 

The chain currently starts at 295+00 and we want to back it up to include the Poplar 
Creek drainage structure. A preliminary look at the vertical suggests that our new 
beginning needs to be at 287+00. To give ourselves additional adjustment room, we 
will extend the centerline back 1000’ to 285+00. 

1) Zoom in on the beginning of the chain to see the changes as we make 
them. 
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2) Before storing any new objects in COGO, we should set the visualization and 
feature. In the COGO dialog, click on the visualization control and set it to 
Permanent Visualization. Click on the Browse button to the right of the 
feature name field. In the SMD item dialog, go to Design and choose feature 
D_POINT.  

 

Once the feature has been selected, click OK to accept. 

Back in the COGO dialog, we can see our feature name has been set. Feature 
D_POINT should be used for centerline COGO set up by Design personnel. 

 

NOTE:  
Temporary Visualization graphics go away when COGO is exited. 
Permanent Visualization writes the graphics to the DGN file so that when 
COGO is exited the graphics remain. 
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3) After review of the existing roadway, we have determined that we can go back 1000’ 
and still be in the same tangent section. Click on the Locate Traverse icon to 
locate and store a new beginning point for our chain. 

 

4) In the Locate Traverse dialog we need to make the following settings as shown.  

Locate Point: D101 (our new point) 

Station Point: S101 (the original beginning point, the point we are locating from) 

Direction: Pa To Pb   TS SC102B & S101 (rather than keying in the 
calculated angle we will use the point to point option to set the direction) 

Distance: Distance 1000 

 

Once the settings are made click on Locate to initiate the command and store the 
new point. 

5) Close the Locate Traverse dialog.  Back in the COGO dialog, we can see our new 
point has been stored. In graphics our point has been visualized.  

Use MicroStation’s Fit View command to find your point graphics. 
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d)  Copy COGO Objects 
In order to keep the copy of the original survey chain intact, we need to duplicate 
the remaining objects in the chain which include a spiral curve, a simple 
curve and the ending point. 

e)  Spiral Curve 
1) Since the spiral curve contains 3 objects (2 spirals and a curve), the simplest way to 

copy it is to just re-define it with a new name. First click on the Redefine option in 
the COGO dialog. Then in the Navigator go to Spirals and double click on one 
of the spirals for curve S102. This opens up the Store Spiral Combinations By 
Tangents dialog with all of the settings for the current curve. 

 

Change the name to DC102 and click on the Store Spiral button. 
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Dismiss the Store Spiral dialog. In graphics, we can now see our spiral curve. 

 

f)  Simple Curve 
2) Since our other curve is just a simple curve, we can just copy it. Click on the Copy 

Curve icon. 

 

In the Copy Curve dialog, key in new curve name DC103, highlight survey curve 
SC103 and click on the Copy Curve button. 
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3) You may have noticed that the curve was visualized in graphics but it is yellow in 
color rather than white. This is because copied elements retain their original feature 
name, in this case survey feature CL.  

Open the COGO Navigator and go to the drop down option Tools → Settings. In 
the Settings dialog, turn on the option for Single Click Enables List Cell 
Editing. Click OK on the Settings dialog. 

 

We need to change the curve’s feature to our proposed centerline feature D_POINT, 
so go to Curve. Click on the feature name CL on new curve DC103. The field 
should open for editing allowing you to key in D_POINT. Once entered hit the enter 
key to finish the change.  
You can Copy & Paste the feature name from the DC102 curve element. 
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As soon as the Feature name is changed the curve is re-visualized.  

 

You can click on the Visualize icon on the COGO Navigator to visualize any 
COGO element (It is the paintbrush icon).  

4) In the COGO Navigator, go back to the drop down option Tools → Settings. In 
the Settings dialog, turn off the option for Single Click Enables List Cell 
Editing. Click OK on the Settings dialog. This should be done to prevent any 
accidental edits. 
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g)  Point 
5) All we need now is our ending point so this time click on the Equate Point icon.  

 

In the Equate Point dialog set the Equate From option to Single Point enter our 
new point name D104 and the Equate To point as S104. Once entered, click on 
the Apply button to store the new point. 

 

NOTE:  
The Equate button can be used to get points from curves and spirals. 

h)  Store Proposed Centerline Chain 
Now that we have all of the objects set up for our proposed centerline, we can store 
that chain. 

1) Click on the Store Chain icon or select Element → Chain → Store → 
From Elements from the COGO menu bar to invoke the appropriate dialog. 

 

2) Key in the chain name SR95, select the Begin Station option and enter a 
beginning station of 285+00 and build the list of COGO elements which will 
become a part of the chain. 

You can fill in the Elements comprising the chain by keyin OR by graphically 
selecting the visualized elements in the design file. Ensure that the elements are 
added to the list in the order which you want them to be stored as a chain. 
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NOTE:  
The Element Selection options on the right of the dialog are only used if desired to 
help build the Element list on the left. 

3) Press Store Chain. Close the Store Chain dialog. 

4) In the output area of the COGO dialog, you will see the command where we stored 
chain SR95. Go to Navigator and click on the describe button to review our new 
chain SR95. You also may wish to describe chain SR95PRELIMINARY to 
compare the two. They should be the same except for the beginning point and its 
station.  

II.) Horizontal Alignment Tools 
These tools are set up to build special curve combinations for interchanges or 
intersections, regular SCS spiral curves or even vehicle turning paths. These include 
3 center curves, taper curves or the complex curve and spiral combinations 
sometimes required for ramps in interchanges. 

To introduce you to these tools in the following exercise, we will assume that it has 
been decided to increase the design speed on our spiral curve (SCS DC102) to 60 
MPH from 50 as it was originally set up. We could look up the spiral lengths for that 
curve and use basic COGO to store it but instead we will use Horizontal Alignment 
tools to design a new curve. 

1) From the Project Manager workflow dialog click on Horizontal Alignment. If 
you have not used these tools before, you will get the prompt “Would you like to 
activate the default design tables?” 

Click Yes. 
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Minimize the COGO dialog. You should see the Horizontal Alignment 
Generator tool bar. 

 

2) First, we need to set some preferences. In the Horizontal Alignment 
Generator tool bar go to the drop down option File → Preferences. 

3) Under the first category Element Symbology set the Label Scale to 50 set 
Grouping to Graphic Group. Don’t worry about setting symbologies. We will use 
other methods to display horizontal alignments. 

 

4) Click on COGO Element Names and set as shown so we can create new curve 
DC104. 
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5) We do not need to change anything under Curve Design Tables since they 
reference tables based on AASHTO green book (“A Policy on Geometric Design of 
Highways and Streets”) standards which are what we use. Skip down to Spiral 
Design Tables and using the browser button load the table 
HA_spiral_emax8.tbl from folder C:\Users\Public\Geopak Standards. This 
table contains spiral lengths and curve values based on superelevation E Max of 
0.080 (8%). 

 

NOTE:  
The following tables are available for spiral curve design and are based on values 
set on T.D.O.T. standard roadway drawings RD01-SE-2 & RD01-SE-3. 

HA_spiral_emax4.tbl E Max 0.040, Urban Desirable 

HA_spiral_emax6.tbl E Max 0.060, Urban Allowable 

HA_spiral_emax8.tbl E Max 0.080, Rural Desirable 

HA_spiral_emax10.tbl E Max 0.100, Rural Allowable 

We will not deal with Turning Paths in this course but we do have the following 
tables that are available for that functionality under C:\Users\Public\Geopak 
Standards. They are based on design vehicles defined in the AASHTO green 
books of 2001 & 2004 with adjustments for Tennessee use. 

HA_Turning_Path_TN_2001english.tbl 

4-18   Coordinate Geometry GEOPAK Road Course Guide 



Exercise 4 

HA_Turning_Path_TN_2001metric.tbl 

HA_Turning_Path_TN_2004english.tbl 

HA_Turning_Path_TN_2004metric.tbl 

6) Skip down to Parameter Formats. Set the Curve Parameter to 
Degree(Arc) and Spiral Parameter to Length as shown. 

 

We are finished setting preferences so we can dismiss the dialog. 

7) Back in the Horizontal Alignment Generator tool bar go to the drop down 
option Tools → Spiral Combinations. This will open the Spiral Combinations 
tool box. 

 

8) We need to store a new SCS curve between tangents so click on the Place SCS 
(Intersecting Elements) icon.  
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9) Set Design Table to 60 mph 4 Lanes and Degree to 2° 30’ 0”. Make sure 
Entry Spiral & Exit Spiral are clicked on, Loop option is off and the Truncate option is 
set to None. Notice that the required spiral lengths are automatically filled in. 

 

10) Before we move on make sure you can see the visualized graphics for our proposed 

centerline. Use MicroStation’s Drop Complex  tool to drop the complex 
status of the complex chain. 

11) Go back to the Place SCS function. In the status bar you may notice that the tool is 
ready to go and is prompting us to Identify first element (look toward the 
bottom status bar, in the middle). Click on the tangent leading to our first curve. 
Click anywhere to accept that and then click on the tangent past the curve to 
initiate curve placement 

 

Click to the left of the alignment to accept that curve solution. 

12) Open the COGO dialog up and review the output window and the spirals and curve 
that we created. 
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13) Now, we need to use our new curve in our chain. Make sure Redefine is clicked on 
and go to the Navigator. Double click on chain SR95. In the Store Chain 
From Elements dialog change curve name DC102 to DC104. Be sure to reset 
the Begin Station option so that the chain’s objects would be re-stationed. By not 
doing so, you might accidently introduce ‘station equations’ into your chain. 

 

Click on Store Chain. 

14) Highlight chain SR95 in the COGO Navigator and click the describe 
button. Review the chain description. Check to make sure the end station is 
347+89.04. 

 

15) You can close the Horizontal Alignment Generator menu bar and tool box since we 
are finished with them. 
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III.) COGO File Functions 
1) To save an input file of your commands or output files of the results, from the COGO 

menu bar, select File → Input File Utility or click on the Input File Utility 
icon.   

2) Set the action option at the lower left to Save, enter a Name such as propcl and 
a Subject description, then click Apply.  

 

All input commands from this session are written to the file propcl101.i**. 
Remember the last 2 letters of the name is your operator code. 

3) For an output file, use the Output option, enter a Name such as SR95, then hit 
Apply. All data currently in the output window is written to sr95101.o**. 

Prior to creating an output file you may wish to use the function 
 View → Command Output → Clear to completely empty the output area. 
Then describe all objects (points, curves, chains, etc.) you wish to save a report on. 
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4) You may review the input file and/or output file by using the GEOPAK Text Editor 
accessed from the Road Tools task set. In the Task pane, scroll down to Road Tools 
and click the expand arrow on the right to open it up. The Text Editor is in the last 
group of tools. 

 

Here is an output of the SR95 chain. 

 

5) Exit the COGO dialog. 
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6) As you exit COGO you may be prompted to save an input file of the session. If you 
haven't, click Yes to save one.      

NOTE:  
It is NOT required that you save when exiting COGO. Data is automatically written 
to the COGO database GPK file and this is just a safety measure. It is only 
recommended when a lot of work has been done so that it could be referenced back 
to later if needed. 

IV.)  Working Alignment – Define Chain 
Now that we have our proposed centerline chain, we have another piece of 
information for the Working Alignment definition.  

1) Access the Project Manager workflow dialog. 

2) Press the Define button to access the Working Alignment Definition dialog. 

3) Highlight the Plan View option and use the Browse button to populate the Chain 
field with our alignment name. 

 

4) Press OK to exit and save the new settings. 
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